AMXBans и проблемы при установке

И как же без проблем связанных с установкой amxbans? Да такого не бывает, вот и у нас возникла проблема с записью в файлах, которые находятся в папках, другими словами у нас не создалась папка templates_c и директории smarty,temp, includes требуют, чтобы стояли права на запись, а мы знаем, что это права с цифрами 777, вот давайте и займемся фиксом проблем связанных с заисью файлов в директориях.

Для начала нам нужно перейти в директорию с нашим скопированным и распакованным amxbans, пишем в консоль:

cd /var/www/html/include/smarty

и создаем папку с названием templates_c, для этого

mkdir templates_c

После каждой команды не забываем нажимать клавишу Enter


(далее…)


Как установить Amxbans на бесплатный веб-сервер от Amazon

Поскольку amxbans не работает с версией PHP 7.0 и выше, то в этом видео мы покажем как с эой проблемой можно бороться.
В прошлом видео https://contra.net.ua/ustanovka-i-nastrojka-phpmyadmin-na-linux.html мы установили phpMyAdmin и настроили
его и сегодня мы продолжим…

Коннектимся к нашему phpMyAdmin и заходим под root.

Нам необходимо создать базу данных для установки amxbans, а также необходимо создать пользователя для этой базы данных:

  1. Переходим во вкладку главной страницы phpMyAdmin (если кому не понятно нажимаем домик слева вверху).
  2. Ниже нажимаем «создать пользователя«.
  3. Во вкладке «Хост» выбираем «Любой хост«
  4. В «Имя пользователя» — набираем с клавиатуры — amxbans
  5. Там где у нас «Создать пароль» нажимаем на кнопку «Генерировать«, после появления пароля добавляем в конце вкладок «Пароль«, «Подтверждение«, «Создать пароль» восклицательный знак или какой-нибудь другой спецсимвол.
  6. Добавляем права для пользователя amxbans, ставим галочки в разделе «Данные«, «Структура«, а в разделе «Администрирование» ничего не ставим.
  7. Нажимаем кнопку «Вперед«, она находится внизу справа.
  8. После создания нового пользователя amxbans, выходим с под root и логинимся под новым пользователем amxbans, если вы зашли в админ панель phpMyAdmin, значит Вы все сделали правильно.
(далее…)

Установка и настройка phpMyAdmin на linux

На linux amazon phpmyadmin не доступен в офф репозитории, поэтому нужно выполнить команду:

amazon-linux-extras install epel

После установки переходим к устанавке phpmyadmin со всеми зависимостями:

yum -y install phpmyadmin

В конце получим:

php-tcpdf.noarch 0:6.2.26-1.el7 php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.26-1.el7 php-tidy.x86_64 0:5.4.16-9.el7 php-xml.x86_64 0:5.4.16-46.amzn2.0.2 t1lib.x86_64 0:5.1.2-14.amzn2.0.2 Complete!
(далее…)

Установка MySQL на бесплатный веб-сервер от Amazon на linux

Поскольку в репозитории linux нет пакета MySQL, то нам необходимо скачать пакет с офф. сайта MySQL. Пишем команду wget https://dev.mysql.com/get/mysql57-community-release-el7-9.noarch.rpm после нажатия Enter, получаем строчку:

Saving to: ‘mysql57-community-release-el7-9.noarch.rpm’ 100%[======================================>] 9,224 --.-K/s in 0s 2019-12-10 08:07:46 (199 MB/s) - ‘mysql57-community-release-el7-9.noarch.rpm’ saved [9224/9224]

Теперь уставновим этот скачанный пакет

rpm -ivh mysql57-community-release-el7-9.noarch.rpm, после нажатия Enter, получим:

Updating / installing... 1:mysql57-community-release-el7-9 ################################# [100%]

А вот теперь установим mysql:

yum install mysql-server
(далее…)

Бесплатный вебсервер Amazon — установка php

Для установки php 5.4 нам потребуется такая команда:

sudo yum install -y php

Нажимаем — Enter и начинается долгожапнная установка php

После установки появится в консоли следующее:

Total 20 MB/s | 4.7 MB 00:00:00 Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : libzip010-compat-0.10.1-9.amzn2.0.5.x86_64 1/4 Installing : php-common-5.4.16-46.amzn2.0.2.x86_64 2/4 Installing : php-cli-5.4.16-46.amzn2.0.2.x86_64 3/4 Installing : php-5.4.16-46.amzn2.0.2.x86_64 4/4 Verifying : php-5.4.16-46.amzn2.0.2.x86_64 1/4 Verifying : libzip010-compat-0.10.1-9.amzn2.0.5.x86_64 2/4 Verifying : php-cli-5.4.16-46.amzn2.0.2.x86_64 3/4 Verifying : php-common-5.4.16-46.amzn2.0.2.x86_64 4/4 Installed: php.x86_64 0:5.4.16-46.amzn2.0.2 Dependency Installed: libzip010-compat.x86_64 0:0.10.1-9.amzn2.0.5 php-cli.x86_64 0:5.4.16-46.amzn2.0.2 php-common.x86_64 0:5.4.16-46.amzn2.0.2 Complete!

Эта запись говорит о том, что Вы все сделали правильно и установили на свой бесплатный сервер php версии 5.4.16